Why are saves from v4.58 unable to play on v4.59+

Anything related to the test branch versions
User avatar
Zaimat
Dev. Team
Dev. Team
Posts: 1409
Location: Toronto, Canada
Contact:

Why are saves from v4.58 unable to play on v4.59+

Post by Zaimat »

Some folks were inquiring about why the test branch versions 4.54 <-> 4.48 are incompatible with the new version 4.59+

The test branch versions had a bug in how they saved some data which made it incompatible with the new Beta 2 (v4.59+) update.

While we could have worked around this, it meant additional time spent fixing something that would only be of limited use. So instead we opted to leave a test branch with 4.58 for those with test games they want to continue playing before moving to the new version.
Horizon - Lead Designer | a.k.a. Raf

User avatar
FrozenFallout
Contributor
Contributor
Posts: 136
Location: USA
Contact:

Re: Why are saves from v4.58 unable to play on v4.59+

Post by FrozenFallout »

Just wondering is there any way to disable the ability to load old saves then, as I had a bad crash that I had to restart from after accidentally loading an old save. I went through and manually deleted the old saves. I didn't load from the Load screen just hit continue then stuck me on a loading screen that I couldn't even force a shut down of the program from ctr alt del.
Image

Grogger
Dev. Team
Dev. Team
Posts: 79

Re: Why are saves from v4.58 unable to play on v4.59+

Post by Grogger »

FrozenFallout wrote:Just wondering is there any way to disable the ability to load old saves then, as I had a bad crash that I had to restart from after accidentally loading an old save. I went through and manually deleted the old saves. I didn't load from the Load screen just hit continue then stuck me on a loading screen that I couldn't even force a shut down of the program from ctr alt del.
Save games between 4.54 and 4.58 can no longer be loaded (in the latest update: 4.61), though older save games should be compatible and loadable.
Do you happen to recall if your crash game version was between (inclusive) 4.54 and 4.58?

User avatar
FrozenFallout
Contributor
Contributor
Posts: 136
Location: USA
Contact:

Re: Why are saves from v4.58 unable to play on v4.59+

Post by FrozenFallout »

Grogger wrote:
FrozenFallout wrote:Just wondering is there any way to disable the ability to load old saves then, as I had a bad crash that I had to restart from after accidentally loading an old save. I went through and manually deleted the old saves. I didn't load from the Load screen just hit continue then stuck me on a loading screen that I couldn't even force a shut down of the program from ctr alt del.
Save games between 4.54 and 4.58 can no longer be loaded (in the latest update: 4.61), though older save games should be compatible and loadable.
Do you happen to recall if your crash game version was between (inclusive) 4.54 and 4.58?

The game I tried to load would have been a 4.58 game when it crashed and was via the continue button but looks like the update fixed using continue to load an old game that is not compatible.
Image